Device Monitoring Studio - Monitor, log and analyze data coming through PC ports and connections
Docs

Protocol Editor

Built-in protocol editor allows you to view and edit predefined and custom protocol definition files. To open a file, use one of the following:

Protocols List Tool Window
Double-click on any file or protocol in a list to automatically open it in the editor.
Generic File » Open… command
Use this generic open command to open a protocol definition file.
Tools » Protocol Editor » Open Protocol File… command
Use this command to open a protocol definition file.
Tools » Protocol Editor » New Protocol File…
Use this command to create a new protocol definition file and open it in the editor. You will be asked for a location and name.

Editor uses syntax coloring (which you may customize as described in the Protocol Editor Coloring section) and provides advanced editing capabilities.

Find

Find Window

Use the Edit » Find… command to bring up the Find window. Enter the pattern to search, configure options and press the Find button. Then use the Edit » Find Next command to jump to the next pattern occurrence.

Replace

Replace Window

Use the Edit » Replace… command to bring up the Replace window. Enter the source and replacement patterns, configure options and then press the Replace or Replace All button.

Go to Line

Go to Line Window

Use the Edit » Go to Line command to bring up the Go to Line window. Enter the line number and press OK button.