Hex Editor - Binary File Editing Software for Windows
Docs

Opening Encoded Hex Files

Hex Editor Neo supports decoding Intel HEX and Motorola S-Records files. You may decode and put them into any opened document using the Edit » Insert Hex… command or open as new documents using the File » Open » Open Hex… command.

Open Hex Dialog

See the Edit » Insert Hex… topic for the window description.

After you execute this command, Hex Editor Neo creates new document and decodes the specified hex file.