Hex Editor - Binary File Editing Software for Windows
Docs

Editor Windows

Editor window is the main Hex Editor Neo element provided for file viewing and editing. These windows are used to display and edit the contents of opened files. This section describes the editor windows in detail.

The new window is opened each time you open or create a new document. Additional windows for a document may also be opened using the Window New Window command. Another way for opening additional editor windows for a document, window splitting is described later in this section.

Basic Elements

Here's a typical editor window:

Editor Window Elements

There are the following elements in each editor window:

Title Bar

Title bar displays the full file name and a close button. Holding a mouse over the title bar displays a tooltip with a full path to the file. Clicking on a close button closes the current editor window. If this is a last window for a given document, the document is closed. In the latter case, you are asked if you want to save any changes made to the document, if there are any.

The Window Close Window command may also be used to close an editor window.

Clicking on a title bar and dragging starts editor window placement customization.

Split Anchor

Split anchor is used to split an editor window into two windows horizontally. Click and drag with a left mouse button to split a window. As a result of your operation, a new editor window is created. It is another view of original window's opened document. Each editor window has its own cursor position, number of columns and view type and its own selection.

After the window has been split, the split anchor disappears, but you can use the splitter bar between two windows to change their relative sizes. As soon as you move the splitter bar to window's top border, the top window is hidden and the split anchor appears again. Note, that the hidden window is not destroyed and all its properties are restored as soon as you split window again.

Hex Editor Neo command Window » Split is used to split the window without using a mouse. If the window has already been split, use this command to hide the top view.

Scroll Bars

As most opened documents are large enough not to fit into their editor windows, scroll bars are used to scroll the file content's through the view, provided by the window. Horizontal scrolling is used to scroll the window's content horizontally, if the current window's size and layout does not allow all the information to be visible. Vertical scrolling is a fast and convenient way to navigate to any portion of the file.

Right-clicking on the scroll bar displays a shortcut menu with following commands (vertical/horizontal):

  • Scroll Here - scrolls to the mouse position
  • Top/Left Edge - scrolls to the beginning of the file/first column
  • Bottom/Right Edge - scrolls to the end of the file/last column
  • Page Up/Page Left - scrolls a few rows/columns backwards/to the left
  • Page Down/Page Right - scrolls a few rows/columns forward/to the right
  • Scroll Up/Scroll Left - scrolls one row/column backwards/to the left
  • Scroll Down/Scroll Right - scrolls one row/column forward/to the right

The vertical scrollbar is disabled if the whole file is visible on the screen. Horizontal scrollbar is disabled if the window fits horizontally and all columns are visible.

Columns' Numbers

To make a file contents more readable, editor windows display the number of each column on the first row. Columns are numbered in hexadecimal, decimal or octal numbers (depending on the way Address Area is displayed) with first column having number zero. The cursor's current column is highlighted if it is visible on a screen.

Each view can be configured to display any number of columns in a row. By default, 16 columns are displayed. The View » Columns command group can be used to change the number of columns. You can choose between standard 4, 8, 16 or 32 columns, specify your own number or select “Auto”. In the latter case, the number of columns is determined automatically depending on the window's width.

When actual number of columns is a power of 2, smart indentation may be applied to a window. In this case, editor window inserts small gaps between columns in a way to greatly increase data readability.

Address Area

For convenience, the address of the first cell in a row is displayed at the beginning of each row. You can configure the address to be displayed as a hexadecimal, decimal or octal number.

The cursor's current row is highlighted and address of the first cell in a cursor row is temporary replaced by the cursor's address. You may switch this behavior off in the Tools » Settings… » General Tab

Data or Code Pane

This pane displays the document's content. Data is displayed in a number of cells, where the cell is a byte, word, double word, quad word, float or double. Cell type is individually configured for each editor window through the View » Display As command group.

More information on data pane is provided in further in the documentation.

Text Pane

This optional pane provides a textual representation of document's content. In editing binary files, it is sometimes convenient to display data in both binary and textual form. This pane is allowed only for Bytes and Words grouping modes.

In word view types, document's data is displayed as an UNICODE (UTF-16) text while in byte view types the window's current encoding type is used to display document's data. You can change the window's encodings through the shortcut menu, or through the View » Encodings menu.

You can turn text pane on or off at any time using the View » Text Pane command.

Cursor

Cursor is a position where subsequent editing commands will take place. This includes typing, inserting or deleting data. The cursor is also used as an anchor point for keyboard selection.

More information on cursor movement and keyboard selection are provided in corresponding sections.