Hex Editor - Binary File Editing Software for Windows
Docs

Structure Editor

Starting from version 6.01, Hex Editor Neo includes built-in Structure Editor. Use this editor to modify any existing structure definition or to create new definitions. The editor has built-in syntax coloring and you may customize used colors as described in Structure Editor Coloring section.

Built-in structure editor allows you to view and edit structure definition files. To open a file, use one of the following:

Structure Library Tool Window
Double-click on any file or structure in a list to automatically open it in the editor.
Tools » Structure Viewer » Library » New Structure File…
Use this command to create a new structure definition file and open it in the editor. You will be asked for a location and name.

Editor uses syntax coloring (which you may customize as described in the Structure Editor Coloring section) and provides advanced editing capabilities.

Find

Find Window

Use the Edit » Find… command to bring up the Find window. Enter the pattern to search, configure options and press the Find button. Then use the Edit » Find Next command to jump to the next pattern occurrence.

Replace

Replace Window

Use the Edit » Replace… command to bring up the Replace window. Enter the source and replacement patterns, configure options and then press the Replace or Replace All button.

Go to Line

Go to Line

Use the Edit » Go to Line command to bring up the Go to Line window. Enter the line number and press OK button.