Hex Editor - Binary File Editing Software for Windows
Docs

Structure Library Tool Window

A structure is defined in a text file (that usually has .h extension). A file may contain one or more structure definitions and may also reference other files with an #include directive. The syntax for structure definition is defined in the Language Reference section.

A Structure Viewer Library is used to manage a list of structure files from which a list of defined structures is taken. To access the Structure Library, open the Structure Library tool window by executing the View » Tool Windows » Structure Library command.

Structure Viewer Library Tool Window

The library window displays a list of managed files and a list of structure definitions, taken from them. They are grouped under the Files and Structures folders correspondingly.

Double-click the file to open its contents in the built-in editor. Double-click the structure name to open its definition file in the built-in editor. Cursor is automatically moved to the structure definition location.

Hex Editor Neo watches for modifications of bound structure files added to the Structure Library. If the file is changed outside the Hex Editor Neo, you are offered to reload and re-scan it.

Library Management

Use the Tools » Structure Viewer » Library » Add Definition File… command to add an existing structure definition file to the library. A file is compiled and a list of error messages is displayed in Output window.

Use the Tools » Structure Viewer » Library » New Definition File… command to create an empty structure definition file and add it to the library. You will be prompted for a file location.

Highlight the file in the library window and execute the Tools » Structure Viewer » Library » Remove Definition File to remove a file from the library.

Compilation

Hex Editor Neo compiles all structure definition files on each launch. It also automatically re-compiles source files when they are modified using built-in editor or by an external program unless the Tools » Structure Viewer » Library » Auto Recompile option is turned OFF. You may manually force the editor to recompile all structure definition files by executing the Tools » Structure Viewer » Library » Compile command.