Hex Editor - Binary File Editing Software for Windows
Docs

Structure Viewer Tool Window

Structure Viewer Tool Window displays structures bound to the current document.

Structure Viewer Tool Window

For each bound structure, its name, type, binding address and coloring sample are displayed. Click on the plus button to expand the structure.

A checkbox on the left to the bound structure controls whether it and the currently selected field are highlighted in the editor window.

After the structure is expanded, all its fields appear on a screen:

Structure Viewer Tool Window

For every field of an expanded structure, you see the name, value, address and field type. As the structure may contain fields whose types are also structures, you may continue expanding them until only built-in types are visible.

The data displayed in a “Value” column is not read-only. You may edit any field by double-clicking on it or executing the Edit » Edit Cell command. When you finish editing a field's value, press the Enter key to submit the changes. The changes are then propagated directly to the current document.

Managing Bound Structures

To bind a new structure, execute the Tools » Structure Viewer » Bind… command. To change the bound structure's properties, double-click it in the list, or select the Edit… option from the shortcut menu.

You may copy the structure's field or the whole structure into the Clipboard using the Copy to Clipboard or Copy All to Clipboard shortcut menu options. Structure may also be exported into the CSV file.

NOTE

Structure viewer limits the amount of data that you can place into the Clipboard. Export to CSV, on the other hand, is capable of processing the entire structure tree, regardless of its complexity, provided you have enough free disk space.

To unbind (delete) a bound structure, select it and press the Del key. You may also select the Unbind option from the shortcut menu.

Execute the Tools » Structure Viewer » Unbind All command to remove all bound structures.

The Tools » Structure Viewer » Display Hex Values switch is used to switch between displaying data in decimal or hexadecimal formats.

The Synchronize Position toolbar command tells the Structure Viewer to synchronize cursor movement between the current editor window and the bound structure.

Autorefresh option (on the toolbar) controls whether the Structure Viewer automatically re-binds all currently bound structures whenever a document changes. It is recommended to switch this option off if you have a complex structure bound.

Press the On-line Repository… toolbar button to open an on-line structure definition repository.

Working with Schemes

All bound structures may be saved as a scheme. To save a scheme, execute the Tools » Structure Viewer » Save Scheme…. Specify the scheme's name and click the OK button.

All defined schemes are then listed in a scheme combo box.

Scheme Combo Box

To load a given scheme, select it in a list. To remove a current scheme execute the Tools » Structure Viewer » Remove Scheme command.