Hex Editor - Binary File Editing Software for Windows
Docs

What's New

Version 6.25

This version adds a few new directives and attributes to the Structure Viewer language, adding look-ahead support to structure binding.

Version 6.20

Version 6.20 introduces the Settings Manager which centralizes application settings management.

Version 6.12

This version adds support for creating volume snapshots and opening files or entire volumes from these snapshots.

Version 6.01

This is a major release. This version introduces the following new modules, technologies and updates to current features:

Updated Data Inspector
This releases updates Data Inspector, adding support for custom types.
Updated Structure Library
Structure Viewer has been updated significantly, featuring separate library tool window, language and stability improvements.
Built-in Structure Editor
This version adds a built-in Structure Editor.
Volume Navigator
Volume Navigator, with support for NTFS volumes is capable of parsing NTFS volume structure on disk.

Version 5.14

This is a bug fix release. Fixed bugs:

Possible crash on startup on 64-bit systems
Hex Editor Neo could crash if launched on some 64-bit systems. Fixed.
Invalid editor window scrolling with mouse wheel
Editor window was scrolled incorrectly using high-resolution mouse wheel. Fixed.
Structure Viewer incorrectly compiled and bound some structures
Structure Viewer could incorrectly compile and bind some structure definitions, namely, the ones that contained huge arrays of static types. It could start allocating more and more memory and binding could take too long. Fixed.
Incorrect file opened after double clicking on error in Structure Errors window
Fixed.
Incorrect handling of multi-byte encodings
The editor incorrectly rendered Text Pane when multi-byte encoding was selected. This bug has been fixed.
Several reported bugs fixed
Several reported bugs, including application crashes, have been fixed.

Updated functionality:

Selection is now retained when number of columns change
Multiple selection is not dropped when you change the number of columns in the editor window.
Installer now keeps user settings on upgrade
Hex Editor Neo's installer now tries to keep user settings during upgrade from previous version.

Version 5.13

Due to significantly better compression of included images (mostly in documentation), this version greatly reduces the installation size and installed disk footprint. In addition, this version fixes following important bugs:

Version 5.12

This release introduces significant improvements to the Structure Viewer. See the What's New in Structure Viewer (version 5.12) topic for more information.

In addition, the following bugs have been fixed:

Crash in disassembler
Hex Editor Neo could crash when you invoked Disassembler in some situations. Fixed.

Updated and new functionality:

Language Pack storage location changed
This release changes the default language pack's storage location, allows user to change it and better supports language packs in portable mode: in addition to user-configurable storage location, language packs are also searched in <program launch folder>\Localization folder.
Some dialogs re-designed
Some dialogs were re-designed to better fit German localization.

Version 5.11

Fixed bugs:

[noindex] and [noautohide] attributes ignored
Structure Viewer ignored [noindex] and [noautohide] attributes. This resulted in incorrect behavior and increased memory usage. Fixed.
Proxy tab was missing from Settings
One of the recent updates incorrectly removed the Proxy settings tab. Fixed.
Crash after pressing Copy in Keyboard Map dialog
Program crashed after you pressed the Copy button in Keyboard Map dialog. Fixed.
Program crashed after saving downloaded update in non-default location
Program crashed when you tried to save to or execute the downloaded update from non-default location.
Structure Viewer's scheme loading bug
Hex Editor Neo could hang if you loaded Structure Viewer's scheme with multiple bound structures. Fixed.

New and updated features:

“All opened documents” mode for Find in Files feature
Find in Files/Replace in Files function now provides “All opened documents” pseudo-location, allowing you to perform an operation on all currently opened documents.
Automatic detection of Language Pack availability
Hex Editor Neo now automatically detects if on-line language pack for user's default language is available and offers to download it.
Improved Structure Viewer performance
Structure Viewer's compilation and binding time reduced by about 10%.

Version 5.10

This release adds support for localization. Language packs are created as part of open source project and will be available through built-in updater once they are finished.

The first available language pack is Russian.

Besides, this release fixes a number of reported bugs. Please consult the View Changes page for detailed information.

Version 5.01

Major update to Structure Viewer
This version has completely new Structure Viewer, with a lot of new functionality and improvements. See the What's New in Structure Viewer (version 5.01) topic for more information.
Parallel operations
Several operations, like Find All and Replace All, now utilize several cores or processors (if they are available). It does not give linear speed-up, but sometimes up to 30% performance gain is obtained. Performance gain is more noticeable in Replace All commands, especially in regular expression mode.
True parallel execution of all lengthy operations
Previous versions allowed you to execute multiple operations in parallel, but user interface was rather limited: for example, it did not allow you to finish the first operation before the second finishes. Now, all started operations are equal and are executed truly in parallel. Application user interface is not blocked. Only windows of the current document are disabled until the operation execution is completed.
Support for Intel HEX and Motorola S files
Advanced Copy & Export now allows exporting selection into Intel HEX and Motorola S formats. In addition, new commands, File » Open » Open Hex… and Edit » Insert Hex… allow the user to convert Intel HEX and Motorola S files to binary form and insert them into the Hex Editor Neo.
Additional information is displayed for several lengthy operations
For Find All, Replace All and other operations, the number of occurrences found so far is displayed on the progress dialog.
Completely rewritten Checksum module

Checksum module has undergone complete rewrite, featuring new algorithms, greatly improved performance and parallel execution. That is, when several algorithms are selected at once, Hex Editor Neo utilizes multiple cores or processors (if they are available) to execute them in parallel.

More hash algorithms are offered (the actual list depends on algorithms available through Cryptography API). More different ways to sum all values in a document or selection are offered, including signed and unsigned sums.

User interface for a Checksum module has also been improved.

Ability to copy/export the current selection
Hex Editor Neo now allows you to get the list of selected ranges into the Clipboard or directly to text file.
Improved experience when opening volumes and disks
Hex Editor Neo is now capable of opening volumes and disks in the same running instance, even if it runs under non-privileged user account.
Goto Navigation panel
Each editor window has its own navigation panel with individual location history.
Improved setup speed
Speed of Hex Editor Neo setup application has been greatly improved. Installer now needs to update less files and system settings and operates much quicker.
Improved application start-up time
We have improved the application start-up time by reducing time required by various components to initialize and allowing several components to initialize in parallel.
Improved Find in Files/Replace in Files commands.
New version provides better utilization of multiple cores as well as proper operation on single-core computers; smoother operation on SSDs.
Improved support for eastern languages
Hex Editor Neo now provides better visual output of eastern languages characters in text pane.

Version 4.97

Support for Using Regular Expressions in Replace Pattern
Replace and Replace All commands now support regular expressions as replace patterns, allowing you to refer to parts of matched expression when performing a replace.
Support for Encodings in all Commands that Work with Regular Expressions
Find, Find All, Replace, Replace All, Find in Files, Replace in Files, Pattern Statistics - all these commands now fully support currently selected encoding when they work in regular expressions mode.
New scripting methods

The following new methods are available in IFileDocument:

Version 4.96

Integration with Windows Error Reporting
Hex Editor Neo now fully integrates with Windows Error Reporting. We will be able to receive each submitted crash or hang report, analyze it and provide a solution to the customer.
New Data Operations – Reverse Bits and Byte Swap
New Reverse Operations commands were implemented in this release. Use the first command to reverse the order of bits in each value in a selection and use the second command to reverse the order of bytes.
New Arithmetic Operations – Set Minimum and Set Maximum
Two new arithmetic operations allow you to limit each value in a selection.
Regular Expression Scheme Association
Structure Viewer now uses regular expressions to match a scheme with a the document.
Improvements in the editor

Various small bug fixes and minor improvements in the editor:

  • Application now remembers the state of the Details Selection tab between launches.
  • Keyboard focus is now moved into the opened document.
  • Shift+Home and Ctrl+Shift+Home keyboard combinations now correctly update selection.
  • Insert Mode can now be switched during editing.
Several Bug Fixes
Several reported bugs were fixed in Structure Viewer (see What's New in Structure Viewer (version 4.96) for more information) and Disassembler. In addition, reported errors in exporting selected data as Delphi array were fixed.

Version 4.95

UTF-8 Support

This release finally adds the UTF-8 to a list of supported encodings. Now it is not only supported in the Advanced Copy & Export module, but also in editor windows, Structure Viewer and everywhere else.

Hex Editor Neo supports single-byte, two-byte, three-byte and four-byte UTF-8 characters. Please note, however, that Hex Editor Neo has limited support for UTF-16 surrogate pairs. See more information on UTF-8 support in the Encodings section.

Encodings in Structure Viewer
This release covers the last “hole” in encoding support in Hex Editor Neo - now Structure Viewer also uses the code page of the current editor window when it displays single-byte character arrays or strings.
Pasting Encoded Text
In this release, Hex Editor Neo also uses the current encoding when pasting text into the Text Pane of the current editor window.
Bug fixes
Several bugs were fixed in the Structure Viewer.

Version 4.94

This release introduces several bug fixes and a few improvements to various product functions:

Portable Installations Improvements

Before this version, when you use the Hex Editor Neo in portable installation, it still uses the target system's registry and file system to store configuration data as well as temporary files.

Version 4.94 of the editor has been modified the following way:

  1. On startup, Hex Editor Neo creates a key in the registry and imports the configuration data from portable.config file (located in the product startup folder).
  2. On exit, Hex Editor Neo saves the configuration data back to this file and removes the registry key.

In addition, Hex Editor Neo stores vector image cache (used to decrease start-up time) in the user's profile temporary folder. You can switch off this behavior in the Tools » Settings…, General Tab.

Version 4.93

This release fixes a number of Structure Viewer bugs and further improves structure binding performance.

Here is a list of all changes in this release:

Version 4.92

General Bug Fixes

General

Structure Viewer

Bug Fixes

New features

Checksum

File Compare

Clipboard

Version 4.91

This version features a completely rewritten setup for Hex Editor Neo.

Transactional Installation

Setup now performs installation of the product as a single transaction (on supported operating systems and configurations, see below). If anything goes wrong during installation, including software or hardware errors, computer configuration is not modified. All setup activities are part of the transaction, including modifications done to the file system and system registry.

Setup always tries to use transactions on supported operating system. If installation fails due to the transaction error, it retries the operation without using transactions. It also does not use transactions on legacy operating systems.

Restart Manager Support

Now, when setup needs to replace or remove a locked file, it uses the system restart manager (Windows Vista or later) to find the application that has a file open. It also offers a way to gracefully restart the application in order to update the file. This new feature greatly reduces the need for system restart during setup.

On legacy operating systems setup emulates the restart manager's behavior, still trying to minimize the need to restart a computer.

Per-User Installation

In addition to the previous, “per-machine” installation mode, a new installation mode is offered. It allows the user to install the application only for himself. In this mode, setup does not modify any per-machine settings. In addition, a user does not have to have administrative rights to install the Hex Editor Neo. After the product is installed in per-user mode, it is not visible to other users of the computer, but may also be installed by them in per-user mode.

Limitations

Take the following limitations into account when installing Hex Editor Neo in per-user mode:

On Windows Vista and later operating systems, standard user (and even computer administrator without elevation) does not have enough privileges to create System Restore points. This does not apply to administrator user on Windows XP computer. Setup always tries to create a system restore point, but will silently ignore this step if it does not have enough privileges.

Portable Installation

Another new installation mode is used to make a portable copy of Hex Editor Neo. Once installed, the copy of the product may be transferred to other locations, or to other computers where it can be used without installation. In this mode setup allows the user to install the product on the removable media and network shares.

Limitations

Take the following limitations into account when installing Hex Editor Neo in portable mode:

Command-line Parameters

New Hex Editor Neo's setup allows you to specify several parameters on the command line:

ParameterDescription
-silentSuppress any user interface dialogs during setup
-uninstall or -uTurn on uninstall mode
-portableTurn on portable mode
-prop INSTALLDIR=[path]Specify the installation folder location. Must end with a backslash.
-userTurn on per-user mode
-machineTurn on per-machine mode

Examples:

This will install Hex Editor Neo in per-user mode into the “c:\Programs\Hex Editor Neo” folder:

hex-editor-neo.exe -user -prop "INSTALLDIR=c:\Programs\Hex Editor Neo\" -silent

This will uninstall the Hex Editor Neo:

hex-editor-neo.exe -u -silent

Version 4.85

Below is a list of changes in Hex Editor Neo 4.85:

Shared Files Support

Hex Editor Neo is now capable of working with files shared with other applications. Using the File » Open » Open Shared File… command you can open a file in the editor, at the same time allowing other applications to make changes to the file.

This feature is supported on all operating systems Hex Editor Neo natively supports. A shared file may be located on a local, removeable or remote media formatted with any supported file system (FAT, FAT32, NTFS, ExtFS…)

After you open a shared file, Hex Editor Neo starts watching for file's modifications. If another application makes changes to a file, Hex Editor Neo displays a Shared File Conflict Dialog, which gives you options to ignore a change, update editor's copy, and/or merge changes with local changes.

In addition, for all “update”-kind options you may instruct the editor to compare the new version with a previous one. Two file comparison algorithms provided by File Compare module are supported. Hex Editor Neo also allows you to retain older versions of a file in the editor. You may edit these old versions as any other kind of document in the editor, save your changes and so on.

Hex Editor Neo also detects file deletion. In this case it gives you an option to close a file or continue working with it, retaining all the changes you made to a file.

A configurable option exists which governs how Hex Editor Neo reacts on file renames. If enabled, renaming a file in another application (like Windows Explorer, for example) automatically changes the file's name in Hex Editor Neo's interface (without any prompts).

Single selection mode option
“Single selection mode” option, which was previously only available in General Settings page (under name "Auto drop selection"), is now also available from the Select menu and on Selection Tool Window's toolbar.

In addition, a number of reported bugs have been fixed in this release.

Version 4.83

This version fixes a potential crash on application exit and introduces new formatted text output format: Assembler array.

In addition, MBR format (for Structure Viewer) definition is fixed (see mbr.h).

Version 4.82

Below is a list of changes in Hex Editor Neo 4.82:

Restore original file attributes
File Attributes tool window now offers a way to restore original file attributes, even after you modify them and apply your changes.
Auto completion in Explorer
Address bar in Explorer tool window now offers autocompletion.
NTFS streams support in File Compare
When compared files are identical, they are also checked for one or more alternate streams. A user is warned if two identical files contain NTFS streams.
2D graph in Statistics.
Statistics Tool Window now provides you with two graphical data representations, instead of one.
Extended goto in Disassembler
Goto command in Disassembler Window now allows you to go to a named function or method. Autocompletion is supported.

In addition, the following reported or known bugs were fixed:

Elevation bugs
When Hex Editor Neo elevates itself (on Windows Vista or later operating systems), elevate.exe process is not terminated and remains running forever. Fixed.
Invalid progress bar
Invalid progress bar is displayed for some operations. Fixed.
Crash in operations
Bitwise, arithmetic, shift and case change operations may crash when used in some configurations. Fixed.

Version 4.81

Below is a list of changes in Hex Editor Neo 4.81:

Full history tree window
You can now view the entire document change history in a special window. History is represented as a tree with a node for each document change. You can quickly switch between states, get more information about each state or execute one of the purge commands. Comfortable zooming and panning features are provided by the window.
Complete rewrite of command routing and toolbar customization system
This release brings completely new version of the command routing and toolbar customization subsystem. We have greatly optimized Hex Editor Neo's startup and runtime performance and brought greater flexibility to user interface customization. Built-in and user-created layouts now not only affect tool windows, but also change commands on default toolbars and size of their buttons.
Checksums and Statistics now store per-document information
Checksums module and Statistics module now store per-document information. For example, you calculate statistics for a document, switch to another one and calculate statistics for it as well. Now, if you switch back to the first document, Statistics tool window will immediately display information it previously calculated for the first document.
Changes in the Free Edition End User License Agreement
Free version's EULA now grants commercial usage of the free edition of the Hex Editor Neo.
Improved Explorer integration
“Edit with Hex Editor Neo” shortcut menu option is now added to drives as well.
Improved Windows dialog
Windows dialog (it displays a list of all opened editor windows) now automatically activates a window under the cursor. There is no need to click the Activate button anymore.

In addition, the following reported or known bugs were fixed:

Several bugs in Structure Viewer

A number of non-critical bugs were found and fixed in Structure Viewer.

32-bit integer types (both signed and unsigned) were incorrectly handled in big-endian mode. Note that this did not affect 32-bit signed and unsigned long types. This bug is fixed as well.

Decrypt function is not working

On some computers it was unable to run a Edit » Decrypt… command. This has been fixed.

A lot of small glitches that were in our “suggestion queue” have finally found their time to be fixed in this release.

Version 4.76

This release focuses on major performance improvement in one of the core Hex Editor Neo components, responsible for working with large files. (Hex Editor Neo considers files bigger than 64 MB on 32-bit systems and bigger than 128 MB on 64-bit systems as large files).

Careful optimizations and wiser use of system resources allowed us to greatly optimize this core component. As performance of most editor functions depends on it, we have managed to improve the speed of various functions from 2x to 8x!

The most boost is displayed in “cheap” operations, like General Statistics and Pattern Statistics, moderate boost in heavier functions as Replace All and less boost in "heavy" functions like Find All, for example.

In addition, document saving performance has also been greatly improved. On some of our test platforms, file copying (File » Open command followed by File » Save As… command) works faster than in Windows Explorer!

In addition, several reported bugs have been fixed.

Version 4.75

New and updated features in this release:

Revised Operation History
User interface for document operation history has been completely revised. Now it is much more comfortable to use one of the most powerful and unique Hex Editor Neo's features - history branches.
Application load-time improvement
A lot of attention in this release has been paid to reduce the time Hex Editor Neo needs to launch.
Offset display type
An offset (or address) may now be displayed as hexadecimal, decimal or octal numbers.
New view types
In addition to hexadecimal, decimal, float and double, data in editor windows may now be displayed as octal and binary values. All Hex Editor Neo's commands and modules are also compatible with new view types, including Copy & Export module.
New range rule type in Pattern Coloring
Pattern Coloring introduces a special rule type: range rule. For range rule, you define a range which is then hilighted in a document.
Advanced support for Editor Window settings
You can now configure the default editor window settings on special settings page (Tools » Settings » Editor). These settings include offset display type, data display type and grouping, byte ordering, a number of columns, character encoding and visibility of code pane and text pane. In addition, there is a special option to associate a different set of window settings for each opened document and restore them next time the document is opened.

In addition, several known and reported bugs have been fixed.

Version 4.73

New and updated features in this release:

Windows 7 Beta support
This release introduces support for new cool features of the Windows 7 Beta taskbar. Progress indication and jump lists are fully supported and utilized by the Hex Editor Neo, and in addition, user is in control of customizing the tasks presented on the taskbar.
Structure Viewer
New structure formats: RAR, ICC, VHD, ZIP, TIFF, WAV, TGA, PSD, PIC, PCX, PAL, EMF, EPS, CAB, MBR, CDA.
New column: Size (to see the size of the field).
See also below for a list of fixed bugs.
File Compare
Recompare Files command added.
Color picker dialogs
A color may now be selected with a double-click.

Bugs fixed in this release:

Structure Viewer

The following bugs are fixed:

  • Nested pointers are not supported.
  • Array size is parsed incorrectly if multiplication is used in size expression.
  • Invalid script file causes a crash.
  • Several parser bugs fixed.
Find in Files
Deadlocks and possible crashes were fixed. In addition, performance for the feature has been increased.
Explorer
Several bugs are fixed in Explorer and it is now compatible with Windows 7 Beta.

Version 4.72

New and updated features in this release:

Disassembler
Version 4.72 brings support for x64 executable files.

In addition, a bug that sometimes lead to program crash has been fixed.

Version 4.71

New and updated features in this release:

Disassembler

Version 4.71 brings support for .NET assemblies. It also features an updated disassembler view window, with support for fast navigation, selection of assembly text, column configuration and much more. It also allows you to display an assembly listing in AT&T format.

Disassembler has an improved quality of the assembly listing. Module imports are now also analyzed and displayed, in addition to symbols.

Structure Viewer

The most of the new functionality is within the Structure Viewer module again. It now understands new built-in types, statements and directives. It also supports variables, constant and variable arrays and expression evaluation with dynamic type inferring.

This release eliminates most of previously imposed limits on structure size, array size etc. The Structure Viewer Tool Window has been updated to easily handle billions of items with very fast and clean navigation. Commands like Expand All and Collapse All will take less than a second expanding/collapsing a structure with a billion of items. If you bind a complex structure to a huge file (for example, AVI), you can estimate the editor to easily carry the job without running out of memory.

A number of handy features, such as Synchronize Position (which works “both sides” - from structure to document and from document to structure), Mouse over field tracking (which highlights a field under the mouse cursor) greatly simplify the file structure analysis.

Structure definitions may extend their functionality by referring to functions written in JavaScript or VBScript. These functions have access to the underlying parser and document, thanks to the IFileDocument and IParser interfaces, exposed to them by the Hex Editor Neo.

The overall compilation and binding performance has been greatly improved.

There is a special topic in this documentation that describes the changes in the Structure Viewer module.

Copy&Export

The Advanced Copy & Export module now follows the model offered by the editor window. It now allows you to execute the Copy and Export commands with no selection present. In this case, a cell under the cursor is copied/exported.

The current byte order is now taken into account when performing copy or export functions.

It also offers an option to configure the number of digits to be exported for floating-point and double precision floating-point types.

Refresh View Command
When working with logical or physical disks, process or physical memory, this command allows you to refresh the editor window to display any possible changes to the underlying data, performed by some other application or operating system.
/s Command-Line Parameter
When launched with “/s” command-line parameter, Hex Editor Neo forwards the list of files to open to an already running instance, if there is one.
“Display cursor address on the left” Option
Several customers complained about the address of the cursor location being displayed at the start of the line. Now this functionality can be switched off. See the General Settings topic for more information.
Reverse Sorting on Statistics Columns
Statistics window now allows you to sort columns in both ascending and descending order in its table mode.
New IFileDocument Methods to Be Called from Scripts

A previously introduced ISequence object was called to make it possible to call methods of the IFileDocument interface from scripting languages (such as JavaScript and VBScript). Although, our tests has shown, that in some cases it is still impossible for a script to call one or another method due to the limitations in the Automation model and the way scripting engines are implemented.

This release finally resolves the problem by providing a special variant of each affected method. Every such variant may be easily called from the scripting languages.

Go to in Process
Go to in Process command now interactively updates the cursor position when you click on the image sections or modules (without closing the Go to window).
UI Sugar

You can now make any tool window appear as a tabbed document. That means that the tool window will not be dockable to one of the four sides of the main window anymore, nor it will float over the main window, but instead will be placed where all editor windows reside. You may then take advantage of the Editor Window Placement feature to position a tool window.

Each tool window now also memorizes its floating position separately of its parent frame.

Ctrl+Mouse Wheel now quickly changes the font size in an editor window. This is a quick way to change a font size without using the Layouts dialog.

The following is a fixed bug list:

Purge All History and Load History Commands
These commands did not work properly in Free Edition mode.
Copy&Paste Bugs
Several bugs with copying and pasting document data have been found and fixed. This may include several application crashes.
A Lot of Minor Bugs
Quite a few of minor bugs or inconsistencies were found and fixed throughout the product.

Version 4.64

New and updated features in this release:

Structure Viewer

Structure Viewer has been completely redesigned and rewritten. It now supports a sophisticated structure definition language with expression evaluation, pointers and bit fields, case unions and assertions, constants and enumerations and much much more.

In addition, C99-compliant preprocessor is run before a source file is compiled, a preprocessor with full support for macros and conditional compilation.

Source files are optimized and saved into precompiled files, which are then quickly loaded by Hex Editor Neo on demand. Structure binding performance has also been greatly increased.

In addition to the ability to bind a structure to an absolute or relative address or to a cursor position, a structure may now be bound to an expression. This expression may reference constants and enumerations declared on the global source file scope or even reference previously bound structures.

Scripting
New Sequence Object provides scripting languages (such as JavaScript and VBScript) a way to build a pattern and pass it to File Document Object methods that require a pattern.

Version 4.51

A number of reported bugs are fixed in this release. Hex Editor Neo version 4.51 introduces a major performance boost.

Thanks to a new internal data structure and handling algorithms, a major performance boost is found in the following functions:

Similar numbers refer to Find in Files and Replace in Files functions.

New features in this release:

Disassembler
Hex Editor Neo now includes a disassembler module. The current implementation is capable of disassembling 32-bit x86 code, including support for FPO, MMX, SSE, SSE2 and 3DNow! instruction sets. Disassembler automatically searches for symbol files and uses the information from them to increase the assembly output readability. The Disassembler View may be connected to ordinary editor window which provides you with another handy data viewing and manipulation tool. The disassembler module works with files and processes' memory and is even automatically updated when you modify the document.
Regular Expressions
Find, Find All, Replace, Replace All, Find in Files, Replace in Files, Pattern Coloring and Pattern Statistics commands and modules now fully support regular expressions. ECMAScript-compatible implementation of regular expressions provides you with extreme power ever found in binary editors. Very efficient implementation of “bulk” commands (Find All, Replace All, Find in Files and Replace in Files) combined with unique features of Hex Editor Neo's multiple selection feature, together form an invaluable editing tool. A concept of named regular expression classes even allows you to define recursive grammars.
Window Switching
Hex Editor Neo now provides fast and convenient tool that can be used to instantly activate any visible tool window or editor window. When you press Ctrl + Tab or Ctrl + Shift + Tab (user configurable), a navigation window is displayed. It provides the list of visible tool windows and all opened editor windows for you to activate. See the Window Switching section for more information.
Code Pane
Hex Editor Neo now provides you with a method to completely hide a code pane, leaving only the text pane visible. Combined with the auto columns mode, it is a powerful tool to edit text or binary-text data.
Default Layouts (Three Different Ones)
When you run the Hex Editor Neo for the first time, you are provided with a choice of default working layout. You can choose between a “Novice User Layout”, "Advanced User Layout" and “Expert User Layout”. You can later change the chosen layout or make your own. See the Default Layout section for more information.

Version 4.41

Version 4.41 fixes a number of reported bugs and introduces some performance optimizations. New features in this release:

Case Change Operations
Hex Editor Neo now offers three new Data Operations: Lower Case, Upper Case and Invert Case. Case change operations take into account current encoding and are capable to work with Unicode data.
Application-Wide Byte Order Support
Hex Editor Neo now fully supports both little-endian and big-endian byte orders. Different byte order can be set separately for each editor window and there is an option that controls whether floating-point types are affected by byte order change. Byte order change commands have been removed from Data Inspector and Structure Viewer modules, as they now respect the byte order configured for a window.
Modify Bits Command
New Modify Bits command allows you to see a visual binary representation of the number and modify individual bits.
Printing Support
Full printing support is now available in Hex Editor Neo.
Copy and Cut Work Without Selection
Copy and Cut commands can now be used when there is no selection in the current editor window. In this case, only the cell under the cursor is copied/cut into the Clipboard.

Version 4.33

Hex Editor Neo version 4.33 fixes a number of reported bugs. Affected modules: Data Inspector, Structure Viewer, NTFS Streams, File Compare.

It also adds the “Hide All Tool Windows” command on the toolbar so you can quickly maximize the workspace and then return to the previous configuration at one mouse click.

Version 4.32

Hex Editor Neo version 4.32 fixes a number of reported bugs and introduces a lot of new cool features. New features in this release:

New Document Types
Hex Editor Neo is now capable of opening volumes, physical disks, process virtual memory and computer physical memory (on supported operating systems).
New Editor Commands

Encrypt and Decrypt commands may now be used to encrypt and decrypt a document (or part of it), using one of the installed block or stream ciphers.

A large set of new data operations: bitwise (NOT, OR, AND, XOR), arithmetic (Negation, Addition, Subtraction, Multiplication, Division and Remainder) and shift (Logical Left and Right, Arithmetic Left and Right and Rotation), are provided. They operate in linear time (depending on selection's complexity), that is, for single-range selection they execute immediately, regardless of data size.

File Comparison
Hex Editor Neo provides two methods, simple comparison algorithm and difference algorithm to locate changes between two files.
Little-endian/Big-endian in Structure Viewer
Structure Viewer may now be switched between little-endian and big-endian data representation.

Version 4.21

Hex Editor Neo version 4.21 fixes a number of reported bugs, provides a number of optimizations as well as introduces new cool features. New features in this release:

Performance Optimizations

This release has undergone several performance optimizations resulted in significant speed-ups in the following commands and features:

  • A special image cache speeds up application loading time. This special cache stores pre-rendered vector images (which are used throughout the Hex Editor Neo) to significantly reduce the application startup time, which was very small even before this cache was implemented!
  • A number of algorithm improvements allowed several editing functions to operate much faster and consume much less RAM. This include typing, inserting and deleting (with complex multiple selection).
  • Several improvements were made to the Find in Files feature, leading to much less memory consumption by this function.
  • File saving algorithms undergone several optimizations leading to smoother and faster saving.
NTFS Streams Support

Hex Editor Neo now fully supports NTFS alternate data streams. A special NTFS Streams Tool Window displays all streams for the currently active file, allows you to delete or rename them, open them for editing or create new streams.

In addition, the powerful Find Stream feature allows you to locate all streams on your computer.

File Attributes has also been updated to display more information related to streams: the total number of streams, size of all file's streams and the total size occupied by a file (including all its alternate streams).

Find in Files now has an option “Include streams” that you may use to include alternate data streams in Search or Search and Replace operations.

Version 4.11

Hex Editor Neo version 4.11 fixes a number of reported bugs as well as introduces new cool features. New features in this release:

Built-In Explorer
Hex Editor Neo now has two Windows Explorer-like windows as part of its user interface. They can be used to perform usual file and folder operations and also tightly coupled with Hex Editor Neo. For example, you can open files in the editor by double-clicking them in the Explorer window simply dragging them to the editor's window.
Encodings
Hex Editor Neo is now capable of displaying text in the text pane according to a selected encoding. More than 130 different encodings are supported (subject to installed code page files and fonts). When the cursor is in the text pane, typed characters are also converted using the selected encoding. Encoding can be set separately for each editor window. Different ANSI, UNICODE, ISO, OEM, MAC, EBCDIC and country-specific encodings are supported.
Checksum Calculation
Hex Editor Neo supports 16 checksum calculation algorithms, including MD5, SHA-1, CRC-16, CRC-32 and others. Custom CRC algorithm is also provided. You can compute the checksum for the whole file or for the current (multiple) selection. Several checksums may be computed at the same time. Results are easily exportable and copyable to the Clipboard.
Advanced Copy & Export
Selected document data may now be converted into a number of supported text formats and placed into the Clipboard or exported to a file. Space-separated or comma-separated numbers, raw text with selected encoding, programming language array declaration, Base64, UUencode and Quoted-Printable are among supported formats.
Pasting Text
Text may now be pasted into the editor. Depending on the active pane, the text is either pasted “as is” (if the text pane is active), or parsed as a sequence of hexadecimal or decimal integers (if the code pane is active).

Version 4.01

Version 4.01 is an absolutely new release, designed and developed from scratch. It does not contain any code from the previous product version.

On the other hand, Hex Editor Neo shares some code base with our Serial Monitor and USB Monitor products, which are part of the Hex Editor Neo product.

Hex Editor Neo retains all interesting and useful features of its predecessor, such as multiple selection, multiple editor windows, vector icons and bookmarks, but implements all these features in a new way, significantly lowering memory requirements and increasing performance and stability.

The performance of all functions has been significantly increased. Several functions that previously executed in several steps now execute in one step (this includes Replace All command, for example).

Hex Editor Neo does not longer support Windows 98 and Windows ME operating systems. But the list of supported operating systems has actually increased:

Pentium III or newer processor is now required by the Hex Editor Neo.

A lot of new features have been implemented in this release. The full list is provided in the Hex Editor Neo's Features section.